AWS Outages

Incident Report for HCE

Resolved

All third parties have returned to normal operation after the AWS operations
Posted Oct 21, 2025 - 08:12 MDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 20, 2025 - 14:35 MDT

Update

We are continuing to investigate this issue.
Posted Oct 20, 2025 - 14:34 MDT

Investigating

Due to ongoing AWS issues Third-party providers are continuing to experience impacts.
Posted Oct 20, 2025 - 09:57 MDT
This incident affected: HCE VPN and HCE Secure Electronic File Transfer (SEFT).